MySQL Forums
Forum List  »  Quality Assurance

Lost connection to MySQL server at 'reading initial communication packet', system error: 0
Posted by: darryl moore
Date: February 19, 2014 10:52AM

Lost connection to MySQL server at 'reading initial communication packet', system error: 0

OK this message is coming up on machines which are supposedly identical, when I try connecting via TCP interface.

I know mysql is listening because I get this erroe when it is not:

ERROR 2003 (HY000): Can't connect to MySQL server on '127.0.0.1' (111)

the other odd thing is when I look at netstat I see this

#netstat -n -l -e | grep tcp
tcp 0 0 0.0.0.0:10050 0.0.0.0:* LISTEN 128 15430
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 120 14278
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 116 452074
tcp 0 0 127.0.0.1:587 0.0.0.0:* LISTEN 0 15278

Notice port 3306 where mysql is suppose to hang out the PID is listed as 452074. The actual PID is 7560 and no PID is suppose to be greater than 65535, so where is this massive number coming from???

I've copied the my.cnf file and the mysql database tables from another machine which does work and restarted, but it makes no difference, I cannot get the TCP connection working. Has anybody seen anything like this before or have any ideas what is going on?

Options: ReplyQuote


Subject
Views
Written By
Posted
Lost connection to MySQL server at 'reading initial communication packet', system error: 0
14315
February 19, 2014 10:52AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.