MySQL Forums
Forum List  »  Quality Assurance

MySQL 5.6.27 will not build on Apple PowerPC G4 under OS X 10.5
Posted by: Alexander Power
Date: October 02, 2015 01:26PM

Hello. I am currently running the GPL-2 licensed version of
MySQL, version 5.6.26, and have been able to compile and run MySQL 5.6 from source for all previous releases through this version. I should state up front that I have been running the database on an Apple PowerBook G4 with OS X 10.5.8 (Leopard). Unfortunately, I have not been able to build MySQL 5.6.27. Failure occurs about 25% of the way through the build. The build log contains the following message:

/mp2/local/var/macports/build/_mp2_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql56/mysql56/work/mysql-5.6.27/storage/innobase/include/os0sync.h:504:4: error: #error "Unsupported platform"

and a few lines later:

:info:build /mp2/local/var/macports/build/_mp2_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql56/mysql56/work/mysql-5.6.27/storage/innobase/include/sync0sync.ic:112: error: "os_atomic_clear" was not declared in this scope

Is MySQL still interested in supporting old Apple PPCs running OS X 10.5? If so, is there a designated place to send the full build log and work with a developer to fix this particular build? Any information would be greatly appreciated.

zanderpower@gmail.com

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL 5.6.27 will not build on Apple PowerPC G4 under OS X 10.5
1202
October 02, 2015 01:26PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.