MySQL Forums
Forum List  »  Router & Proxy

Re: mysqlrouter is Unable to connect to the metadata server
Posted by: IGG t
Date: July 25, 2019 03:57AM

I think I have solved it.

It appears that there is a difference between Group Replication and Innodb Cluster that perhaps needs to be made clearer in the documentation.

Anyway, I ran:

mysqlrouter --bootstrap root@[::1]:3306


and got:

Error: Expected MySQL Server '::1:3306' to contain the metadata of MySQL InnoDB Cluster, but the schema does not exist.
Checking version of the metadata schema failed with: Error executing MySQL query: Unknown database 'mysql_innodb_cluster_metadata' (1049)

This was the first clue that something was missing. Then I eventually found the following:

https://dev.mysql.com/doc/refman/8.0/en/mysql-innodb-cluster-from-group-replication.html

This tells you that you need to "convert" group replication to an Innodb Cluster by running:

var cluster = dba.createCluster('prodCluster', {adoptFromGR: true});

This tells you that:

A new InnoDB cluster will be created based on the existing replication group on instance 'localhost:3306'.

After that I tried bootstrapping mysqlrouter, and it worked.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: mysqlrouter is Unable to connect to the metadata server
1398
July 25, 2019 03:57AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.