MySQL Forums
Forum List  »  MySQL Workbench

Workbench 5.0.11 OSS on Win2k
Posted by: Jeremy Druker
Date: December 22, 2007 03:42PM

As a die-hard 2k user, I was a bit disappointed to see that Workbench now requires XP, and I wondered exactly why.

From what I can tell, the only reason it won't run on 2k is a minor one: two XP-only API's (GetDllDirectory and SetDllDirectory) are used when loading mysql.canvas.dll at startup, in backend\workbench\canvas_selector.cpp

Making that piece of code 2k-friendly was not much work, and having done that Workbench now seems to run on Win2k. At any rate, it fires up correctly (previously it crashed before even showing the splash page) and I've made some trivial edits, and saved and loaded the model file OK, so it looks promising.

If this is of interest to anybody, I'll be glad to share my changes, which really are quite trivial. Leave a reply here if so.

-J



Edited 1 time(s). Last edit at 12/22/2007 03:49PM by Jeremy Druker.

Options: ReplyQuote


Subject
Views
Written By
Posted
Workbench 5.0.11 OSS on Win2k
7143
December 22, 2007 03:42PM
4457
January 10, 2008 09:10AM
4105
January 10, 2008 09:22AM
5446
January 22, 2008 01:18PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.