MySQL Forums
Forum List  »  MySQL Workbench

Trigger updated for renamed table, yet old version of trigger appears in Forward Engineer SQL Create
Posted by: Ken Zo
Date: June 21, 2008 12:05AM

In Workbench (5.0.22 OSS), I created a two triggers for a table. Then I renamed the table. Then I changed the triggers to refer to the new table name.

In the table edit view->triggers tab, the two triggers are displaying correctly, referring to the new table name.

But, when I Forward Engineer SQL Create, the script that's generated has one of the two triggers still referring to the previous table name! This is a bug in the script and prevents MySQL from processing the whole script.

In Workbench, I tried removing the triggers, then adding them again. No luck - it still looks right in Workbench, yet shows up wrong in the Create script.

Any ideas? Is there a workaround (i.e. via the GRT shell?) where I can locate the pesky artifact and correct it?

(I've been using this program for three days and I'm pretty amazed at how buggy it is! It's a great program with a lot of potential, but so many features just don't work correctly. It really ought to be considered beta software. If I'd known so many things weren't working yet, I would've saved a lot of time and not used it. Oh well!)

Options: ReplyQuote


Subject
Views
Written By
Posted
Trigger updated for renamed table, yet old version of trigger appears in Forward Engineer SQL Create
2980
June 21, 2008 12:05AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.