MySQL Forums
Forum List  »  MySQL Workbench

safe update mode
Posted by: Keith Bernard
Date: August 11, 2010 10:17AM

Hi

I am fine with MS SqlServer but fairly new to mysql

When trying to do a simple update
(e.g. update `myTestTable` set f1=499 where f1='449';)

with the latest MySQL Workbench 5.2.26 CE version 6432 I get this error message:

Error Code: 1175
You are using safe update mode and you tried to update a table without a WHERE that uses a KEY column

I don't believe I got this with the previous version 5.2.25.

If I use phpMyAdmin it simply works...

In my normal htdocs/mysql/bin/my.ini file (I use Xampp so my docroot is htdocs) I have the following lines which appear to stop this mode:

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates



Is there somewhere else that I need to change just for MySQL Workbench to work the same ? I am sure it should be something fairly simple!

Thanks

Options: ReplyQuote


Subject
Views
Written By
Posted
safe update mode
32516
August 11, 2010 10:17AM
11075
August 11, 2010 11:21AM
7124
September 14, 2010 07:23PM
7378
August 12, 2010 01:40AM
6059
August 12, 2010 07:16AM
5255
August 18, 2010 07:37AM
5158
August 23, 2010 06:39AM
2450
August 24, 2010 10:52AM
1906
September 13, 2010 09:51PM
1959
September 14, 2010 06:25AM
3032
September 23, 2010 10:00AM
1959
September 13, 2010 05:13PM
2134
August 30, 2010 02:46PM
2392
November 05, 2010 03:35PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.