MySQL Forums
Forum List  »  MySQL Workbench

Queries say they return rows, but no rows shown. Tables etc just show as "fetching"
Posted by: Darren Coleman
Date: September 30, 2017 02:37PM

Hi,

I'm running the latest MySQLWorkbench 6.3.9 on MacOS 10.13.

When I connect to a database remotely (over SSH) I can connect fine, but queries do not work. What seems to happen is that I'll execute a basic SELECT query, it will tell me how many rows are returned at the bottom, but it will not actually show any rows at all. Attempting to run the same query again shows a progress wheel next to the query tab which continues indefinitely.

Also, attempting to list tables for any database shows "Fetching" for tables, views, etc.

Note: I can fetch tables, views, etc BEFORE I try to run a query (any query). After that, it never works.

I have already run mysql_upgrade, so that's not the problem. I also have no issues connecting at all, so I don't think the connection is wrong, though I have tried disabling SSL, leaving it as "If available" etc, compression on and off, nothing seems to work.

I have also tried a competing product with the same settings & database and that has no problems at all, so I'm convinced the problem is localised to MySQLWorkbench.

I have also tried using older versions (down to 6.3.3), and completely removed it from my system including the configuration and reinstalled, etc.

Looking for some help - thanks in advance!

Options: ReplyQuote


Subject
Views
Written By
Posted
Queries say they return rows, but no rows shown. Tables etc just show as "fetching"
311
September 30, 2017 02:37PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.