MySQL Forums
Forum List  »  MySQL Workbench

Re: Error Code: 2013. Lost connection to MySQL server during query
Posted by: David Garratt
Date: May 18, 2019 10:43AM

Personally I think it's a MacOS issue. I have noticed that tools like Navicat can also experience connection problems with mySQL and there is a note on their web page saying how to increase the timeout within the app. Having said that increasing the timeout value does not help.

What I really need to know is the correct location for cn.inf on MacOS assuming I have used the installer to install to the default location.

I tried putting on into /etc and specifying it's location in the MacOS mySQL control panel. However after a restart the Admin pane of mySQL Workbech still reports that the config file is unknown.

Other activities which you would expect problem actually work. For example I have written a java program which copies records between databases 1 row at a time and that will process millions of records without problem.

It's the initial connection which fails normally.

I don't have a firewall running. I'm using a MacBook Pro with it's wifi adapter having an active connection. This macbook does not have a cabled ethernet port.

I have tried the sql command line to set a very hight connection timeout but I suspect it won't help as it's the jdbc client connection which is failing before it's even looked at the database to determine what the timeout value is.

This isnt a new problem. I've had 3 MacBook Pro's with the same issue and I've seen it even after a clean install and no other apps installed.

Very curious. I might install mySQL Server on a windows machine and see if I have problems connecting to that from my Mac as well.


Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.