MySQL Forums
Forum List  »  MySQL Workbench

Can't start/connect to localhost server, Mac OS Mojave.
Posted by: Jason Kwong
Date: August 15, 2019 09:19PM

Hi all,

I'm getting quite frustrated having spent hours and hours trying to get MySQL and workbench working. I'd deeply appreciate it if any can help. I've downloaded the MySQL 8.0.17 and Workbench 8.0.17. I am running on Mac OS Mojave 10.14.6.

**PROBLEM: **
I have the MySQL server RUNNING (it says running in Systems Preference -> MySQL) and yet start a local server on my laptop. After I connect to the default local instance 3306, it says server status is stopped and there is no connection. When I try pressing the start server button in "Instance" -> "Startup/Shutdown", it says "Command to start the server is not configured. Please set the command that must be used to start the server in the remote management section of this connections settings."

I have also tried Setting up my own connection, using Standard TCP/IP, Hostname-127.0.0.1, port 3306, username -root. When I test connection, it says "Can't connect to MySQL server on '127.0.0.1' (61)".


**Things I've Tried/Useful information: **
I've tried many things by following things online. Here are some information that may help:

1) On terminal, I've typed in "/usr/local/mysql/bin/mysql" and it brought me to "MySQL>". I typed in "SHOW GLOBAL VARIABLES LIKE 'PORT';" and it says
| Variable_name | Value |
+---------------+-------+
| port | 0 |

I looked this up and apparently it may have to do with skip network.
I then typed "SHOW VARIABLES LIKE 'skip_networking';" and it says
+-----------------+-------+
| Variable_name | Value |
+-----------------+-------+
| skip_networking | ON |
+-----------------+-------+

Apparently I should turn it off, but I don't know how. There's some stuff about typing "sudo nano /etc/mysql/my.cnf" and editing the file, but I've tried many many different locations, /.../my.cnf but it always comes up with a blank "new file". I also don't seem to have a /etc/ file in general.

2) After typing in "defaults read /Library/LaunchDaemons/com.oracle.oss.mysql.mysqld.plist"
It reads:
{
Disabled = 0;
EnvironmentVariables = {
"MYSQLD_PARENT_PID" = 1;
};
ExitTimeOut = 600;
GroupName = "_mysql";
KeepAlive = {
AfterInitialDemand = 1;
SuccessfulExit = 0;
};
Label = "com.oracle.oss.mysql.mysqld";
LaunchOnlyOnce = 0;
ProcessType = Interactive;
Program = "/usr/local/mysql/bin/mysqld";
ProgramArguments = (
"/usr/local/mysql/bin/mysqld",
"--user=_mysql",
"--basedir=/usr/local/mysql",
"--datadir=/usr/local/mysql/data",
"--plugin-dir=/usr/local/mysql/lib/plugin",
"--log-error=/usr/local/mysql/data/mysqld.local.err",
"--pid-file=/usr/local/mysql/data/mysqld.local.pid",
"--keyring-file-data=/usr/local/mysql/keyring/keyring",
"--early-plugin-load=keyring_file=keyring_file.so"
);
RunAtLoad = 1;
SessionCreate = 1;
UserName = "_mysql";
WorkingDirectory = "/usr/local/mysql";
}

I've seen when other people do this they show a line towards the end after the "pid-file" line that tells you the port ID. It doesn't in mine and instead gives me the "keyring-file" and "early plugin" line.


3) Whenever I connect to a server (be it localhost / 127.0.01), it doesn't ask me for a password, but it seems to do so on other people's computers.

Thanks very much. Any help is deeply appreciated.

Options: ReplyQuote


Subject
Views
Written By
Posted
Can't start/connect to localhost server, Mac OS Mojave.
368
August 15, 2019 09:19PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.