MySQL Forums
Forum List  »  MySQL Workbench

Re: why mysql workbench could not import pyodbc module
Posted by: Andrew Symons
Date: November 23, 2020 03:37PM

As a Workbench newbie, I have this problem too on MacOS and have spent several hours trying to solve it, so far with no luck. My aim is to migrate from Filemaker (in a local file) to MySQL (hosted on a cloud). I have enabled Filemaker ODBC.JDBC and created a driver using ODBC Manager.

Part of the problem is that MySQL Workbench does not say where it is trying to import pyodbc from or which version of Python it is using.

Based on postings on other sites, I have already
. Downloaded Python 2.7 to be on the safe side, though it was already there
. Downloaded Python 3.9 as this is the current version
. Downloaded pip for each of these (pip2 and pip3)
. Downloaded and installed MySQL pyodbc (4.0.30) in both Pythons 2.7 and 3.9
. Also downloaded the UNIX pyodc modules (because someone suggested it)
. Also downloaded the MS pyodc modules (because someone suggested it)
. Tried 'import pyodbc' in each of the Pythons (running interactively in Terminal) not a problem there!

All of these worked individually (whether they are necessary is another question), yet still I cannot get beyond the first migration step, which says "Could not import the pyodbc python module. You need pyodbc 2.1.8 or newer for migrations from RDBMSes other than MySQL.


Options: ReplyQuote

Written By
Re: why mysql workbench could not import pyodbc module
November 23, 2020 03:37PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.