MySQL Forums
Forum List  »  MySQL Workbench

ODBC Administrator utility could not be found (32-bit vs 64-bit)
Posted by: Phil Mayne
Date: February 25, 2023 02:16PM


This is my first foray into using MySQL. I'm trying to migrate a 64-bit Microsoft Access database to MySQL but I'm falling at the first hurdle.

This is my setup:

64-bit Windows 11 Home, version 22H2
64-bit Microsoft Access 2019
64-bit Microsoft Access Runtime (tried version 2010, 2013 and 2016)
64-bit MySQL Community 8.0
64-bit MySQL Connector/ODBC 8.0

If I run odbcad32.exe from Start/Run, Windows launches the 64-bit ODBC Administrator app (from Windows/System32) and I can see the 64-bit ODBC drivers and maintain my DSNs. This proves that Windows, at least, recognises that my set up is 64-bit.

However, if I launch MySQL Workbench Migration Wizard and click on the "Open ODBC Administrator" button, I get an error message that says:

"Open ODBC Administrator. ODBC Administrator utility could not be found"

At the same time the application opens the 32-bit ODBC Administrator (from Windows/SysWOW64), not the 64-bit app. This means I can't import my 64-bit Access databases into the Migration Wizard.

I've found quite a few instances where others are reporting similar behaviour but have not found any advice that fixes my problem. I've searched this forum for the exact error message I'm getting but there are no hits.

I'd be really grateful if someone could help me out with this.

Many thanks.

Options: ReplyQuote

Written By
ODBC Administrator utility could not be found (32-bit vs 64-bit)
February 25, 2023 02:16PM

Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.