MySQL Forums
Forum List  »  Data Recovery

--one-database not working
Posted by: Alessio Vitale
Date: February 11, 2010 04:49PM

Hi all,
i tried to restore a db from a full mysqldump backup.
These is my backup command:

mysqldump -uroot -ppassword --all-databases --single-transaction --flush-logs > C:\alldb.sql

When a try to restore only a db mysql ignore this option and it restore all dbs in my dump


mysql --uroot -ppassword --one-database mydbname < C:\alldb.sql

I tried this too

mysql --uroot -ppassword --database mydbname < C:\alldb.sql


mysql --uroot -ppassword mydbname < C:\alldb.sql

Nothing changes.

My server runs windows vista and mysql 5.1 with innodb as default storage engine.

Thank you in advance

Edited 3 time(s). Last edit at 02/11/2010 04:52PM by Alessio Vitale.

Options: ReplyQuote

Written By
--one-database not working
February 11, 2010 04:49PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.