MySQL Forums
Forum List  »  Data Recovery

Replication Fails when removing function
Posted by: Richard Meadows
Date: September 05, 2011 01:11PM

I am having trouble with MySQL replication when stored functions are created or removed.

Replication to my 5.1 MySQL slave fails with error 1548 'Cannot load from mysql.proc. The table is probably corrupted'. I have tried repairing mysql but the table isn't corrupt. Also ran mysql_upgrade as I heard that it can fix issues with store procedures. The error happens when functions are replicated. I have set log_bin_trust_function_creators=TRUE. Even tried turning off replication of the mysql database using 'replicate-ignore-db=mysql'.

The master database is running MySQL 5.5.8. Is there some incompatibility between version 5.1 and 5.5.8?

Options: ReplyQuote

Written By
Replication Fails when removing function
September 05, 2011 01:11PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.