MySQL Forums
Forum List  »  Data Recovery

Replaying logs with mysqlbinlog
Posted by: Paul O'Connor
Date: May 06, 2014 08:34AM

I'm getting a "server has gone away" error trying to replay logs with mysqlbinlog.

The set up is:

MySQL 5.6 on Windows 2008

MyISAM all the way.
Master - Slave replication is set up and is working well. It's using RBR.

Once per week I issue "FLUSH LOGS" then a "FLUSH TABLES WITH READ LOCK" on the master before copying ( ROBOCOPY ) the db in question from the data directory to a backup location.

The problem is on a 3rd machine (dev) machine.
I stop MySQL and copy the backup of the db over onto this machine directly into the data folder and restart MySQL. It all works well up to this point.

I get the error when I try to replay a log using mysqlbinlog:

mysqlbinlog --force-read binlog.filename | mysql -f

I've tried without the --force-read and -f but get the same result.

Not sure what to try next, anyone have suggestions?


Options: ReplyQuote

Written By
Replaying logs with mysqlbinlog
May 06, 2014 08:34AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.