MySQL Forums
Forum List  »  Data Recovery

Error Code: 1932. Table 'MYDB.MYTABLE' doesn't exist in engine
Posted by: Bender Rodriguez
Date: December 23, 2015 03:43AM

I am a newbie to Mysql/Mac OS. Yesterday I turned my laptop (Yosemite 10.10.5) on and found that mysql workbench 6.3 was complaining when retrieving data from one of my tables:

Error Code: 1932. Table 'mydb.mytable' doesn't exist in engine

I cant think why this would suddenly start happening. The ibd file is 2.4GB but I guess that makes no difference.

The table is stored in INNODB format.

All I need to do is get the data, even if its in a text file or something, I dont care about relinking the data back into MySQL. At this stage all I care about is the data.

I've tried various things:

-innodb_force_recovery (values from 0-6) (same error occurred)
-PERCONA innodb recovery tool (i couldnt get it to compile)
-deleting and recreating tablespaces (same error occurred)
- - but this does not give me the error he says it should, hence he thinks I should be able to dump my table (which I cant) as the same error occurs.

I'm at my wits end. Is there any way to get my data back? Any advice much appreciated.

Options: ReplyQuote

Written By
Error Code: 1932. Table 'MYDB.MYTABLE' doesn't exist in engine
December 23, 2015 03:43AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.