MySQL Forums
Forum List  »  Connector/C (libmysql)

MySQL 8 client connector — "bad handshake" with older servers
Posted by: Seth Willits
Date: May 22, 2018 06:06PM

Using libmysqlclient from 8.0.x to connect to older versions of MySQL 5 (5.0, 5.1) ends up with a "bad handshake" (1043) error — but connecting to newer versions (5.7) works fine. Any idea if there's a particular setting that influences this? I'm not sure what's causing it. The older servers are not using old 4.1-style password hashing.

I'm puzzled.

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL 8 client connector — "bad handshake" with older servers
19755
May 22, 2018 06:06PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.