Re: Versioning with Connector/C and MySql
Posted by: Steve Yates
Date: May 25, 2021 11:21AM

What platform are you on?

We have a mixed Windows/Linux environment and are in the middle of doing just that. On the Linux side there have been no issues. On the Windows side, the Connector/C library only goes up to 6.1.11. Which will not authenticate against a MySQL 8.0.24 db - unless you enable legacy authentication on the server side.

Connector/C 6.1.11 is only on the Windows side. There are connector/C 8.0+ versions for Linux ... Windows Connector/C only going up to 6.1.11 is causing us problems. I'm at the point where I'm going to talk to our db admin and have him enable legacy authentication.

As far as anything we have done, we haven't had to make any changes to the code for connector/C 8.0 on the Linux side.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Versioning with Connector/C and MySql
222
May 25, 2021 11:21AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.