MySQL Forums
Forum List  »  MySQL Shell

Building mysql-shell antlr4 runtime issue
Posted by: Julio Suarez
Date: September 29, 2023 03:16PM

HI All,

Building mysql-shell, I get the error below. Issue is, I'm including the runtime dir, but it still doesn't seem to work. To get the runtime dir, I am building antlr4 which puts its runtime dir at ~/antlr4/runtime.

Setting antlr4-runtime_DIR like below still yields the error (I've tried both absolute path and relative path).

Not sure what I'm doing wrong. I've also tried package installs of antlr4.

cmake antlr4-runtime_DIR=~/antlr4/runtime .. -DMYSQL_SOURCE_DIR=/home/ubuntu/mysql-server -DMYSQL_BUILD_DIR=/home/ubuntu/mysql-server/bld -DPACKAGE_YEAR=2023 -DHAVE_PYTHON=1 -DCMAKE_CXX_FLAGS="-Wno-error=maybe-uninitialized" -DCMAKE_C_FLAGS="-Wno-error=maybe-uninitialized"

CMake Error at CMakeLists.txt:628 (find_package):
By not providing "Findantlr4-runtime.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"antlr4-runtime", but CMake did not find one.

Could not find a package configuration file provided by "antlr4-runtime"
with any of the following names:


Add the installation prefix of "antlr4-runtime" to CMAKE_PREFIX_PATH or set
"antlr4-runtime_DIR" to a directory containing one of the above files. If
"antlr4-runtime" provides a separate development package or SDK, be sure it
has been installed.


Options: ReplyQuote

Written By
Building mysql-shell antlr4 runtime issue
September 29, 2023 03:16PM

Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.