MySQL Forums
Forum List  »  General

MySQL Not Respecting tmpdir option
Posted by: J Donley
Date: January 21, 2019 06:27PM

I'm seeing odd behavior that does not match the documentation nor responses to threads in this and similar forums. MySQL appears to be ignoring the tmpdir setting.

I have set the tmpdir variable in my.ini to a directory in another drive (E:). This happens to be the drive that I installed mysqld, the workbench, etc onto. The valu3e I set is E:/mysqldata/tmp, for the sake of clarity. When I query for this variable with SHOW variables like tmpdir, this value is in the response. This is set in the default template for my.ini that is shipped with MySQL so this variable is under [mysqld].

If I try adjusting the value to E:\mysqldata\tmp or /mysqldata/tmp, the service will not start so there is an indication that the format is correct. At least the other formats appear to be incorrect.

Once the service starts, I do see a handful of files in the mysqldata/tmp directory created after I clear out its content. So it appears that the Workbench is writing some temp data to the directory in the my.ini file. However, when DML on large data runs, a series of 512MB files are added to C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp. My guess based on threads in this forum is that this is the default location for tmp files which is the failover if no other variable (like tmpdir, tmp) is set.

Obviously this is incorrect. Also, this is not the drive that MySQL is installed on so this problem is all the more perplexing. I am unable to work because my C drive does not have the space for this volume of data.

Any help is greatly appreciated.
J

Options: ReplyQuote


Subject
Written By
Posted
MySQL Not Respecting tmpdir option
January 21, 2019 06:27PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.