MySQL Forums
Forum List  »  MyISAM

Re: Optimize Table Taking Forever
Posted by: Thomas Cleveland
Date: April 30, 2012 10:12AM

Well I tried a regular kill on my replicant. Then processlist showed the command as 'Killed' but it stayed there indefinitely, locking the table and preventing the next entry in the log being executed. I tried killing it again, which didn't work, so I then tried to shut down mysql, but that also just hung.

In the end I restarted the server then started up mysql again, and started the slave, but immediately killed the optimize table, and this time it worked. It disappeared from the processlist and my replicant began the long process of catching up.

It seems this is a known bug (#25421) that I think has been fixed in later versions.

Options: ReplyQuote

Written By
April 27, 2012 03:03AM
April 30, 2012 12:32AM
Re: Optimize Table Taking Forever
April 30, 2012 10:12AM
May 01, 2012 10:14AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.