MySQL Forums
Forum List  »  InnoDB

Re: InnoDB on RHE3 buffer pool swapped out..
Posted by: James Day
Date: April 25, 2005 04:52PM

I disable swap completely. It's a bad solution but better than the alternatives.

In service I find that any significant presence of swapping (even soft page faults) can have a significant effect on performance and it's more important to prevent that than to maximize cache size.

If your server isn't dedicated to the database, particularly if it's also running Apache, I suggest lowering the RAM allocation instead of disabling swap. You can count on incoming Apache connections causing you to exceed available RAM, so it's vital to have swap available.

On some Fedora Core versions around late 2 and early 3 there's a bug where disabling swap can cause 100% CPU usage from kswapd; changing to a different build or using a tiny amount of swap are the workarounds. There are options for changing how keen the OS is to swap but those seemed to have no significant effect. I wasn't using O_DIRECT, so there was great cache pressure on the OS. I don't know how applicable this paragraph is to RHE3 but it's here for completeness and the benefit of other readers.

You may also find benefit from carefully considering and perhaps reducing the sizes you allocate to per-thread buffers. Reducing them can decrease the chance that connections will cause swapping. Particularly important not to have overly large settings when swap is turned off.:)

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: InnoDB on RHE3 buffer pool swapped out..
2212
April 25, 2005 04:52PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.