MySQL Forums :: InnoDB :: Could not increase number of max_open_files to more than 65536 (request: 1050635)


Advanced Search

Re: Could not increase number of max_open_files to more than 65536 (request: 1050635)
Posted by: Jon Stephens ()
Date: January 11, 2017 01:04PM

Hi,

This has to do with the mysqld option --open-files-limit and its interaction with any limits set by the system for nofile in your /etc/security/limits.conf file, as well as with values of some other mysqld options. See How MySQL Opens and Closes Tables for an overview.

You can reduce the values for the mysqld options, or reduce your workload, or you can possibly increase any nofile limits set in limits.conf. See your system documentation for specifics on the latter.

I am not really an expert in tuning, so I won't try to contribute any more to this thread--but the info I've linked to should be enough to get you started.

Jon Stephens
MySQL Documentation Team @ Oracle
Stockholm, Sweden

MySQL Dev Zone
MySQL Server Documentation
Oracle

Options: ReplyQuote


Subject Views Written By Posted
Could not increase number of max_open_files to more than 65536 (request: 1050635) 357 lee fei 01/05/2017 09:47PM
Re: Could not increase number of max_open_files to more than 65536 (request: 1050635) 246 Jon Stephens 01/11/2017 01:04PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.