MySQL Forums
Forum List  »  InnoDB

recovering InnoDB
Posted by: Thor Pfosten
Date: September 28, 2017 02:33AM

Hi there,

with a database "mymediawiki" I ran into serious trouble. The
database consists of InnoDB tables.

I can see the tables with the "show tables"-command
like so:

mysql> show tables;
| Tables_in_mymediawiki |
| archive |
| table3 |
| table3 |


However, when I try to access a
table I get the error message, that the table does not exist:

mysql> select * from archive;
ERROR 1146 (42S02): Table 'mymediawiki.archive' doesn't exist

mysql> repair table archive;
| Table | Op | Msg_type | Msg_text |
| mymediawiki.archive | repair | Error | Table 'mymediawiki.archive' doesn't exist |
| mymediawiki.archive | repair | status | Operation failed |
2 rows in set (0,01 sec)


Then I tried to repair the tables on the shell:

# cd /var/lib/mysql/mymediawiki
# mysqlfrm --basedir=/etc/mysql --user=mysql mymediawiki:archive.frm --port=3333
Spawning server with --user=mysql.
Starting the spawned server on port 3333 ... ERROR: Cannot find location of mysqladmin.

So as you can see it is the database of a wiki. Maybe someone has experience with
this special situation.
Can you get started on how to recover the database ?

Thanks a lot.


Options: ReplyQuote

Written By
recovering InnoDB
September 28, 2017 02:33AM
September 28, 2017 10:03AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.