MySQL Forums
Forum List  »  Performance

no match variable
Posted by: Roman Smirak
Date: October 18, 2004 08:22AM

Hello,

* I would like to set variables related to memory (i.e. key_buffer_size, table_cache, read_buff_size, etc.)
* I have tried to set the variables in context of my.cnf (in context of [mysqld] section), I have tried to use params directly from command line using -O, --set-variable, or --key_buffer_size (with and without _size postfix)
* that produced following error: no match variable: -O 'key_buffer_size=64M', because of:
* enabled variables are following:
[root@backupserver bin]# mysql --help
Possible variables for option --set-variable (-O) are:
connect_timeout current value: 0
max_allowed_packet current value: 16777216
net_buffer_length current value: 16384
select_limit current value: 1000
max_join_size current value: 1000000
* => I can't set key_buffer_size, but:
[root@backupserver bin]# /usr/bin/mysqladmin variables | grep key_buffer_size
| key_buffer_size | 8388600 |
* is included into system.

** Question: how to set e.g. key_buffer_size variable ?

MySQL version: 3.23.49
OS: RH Linux 7.3 2.96-110

Thanks, Roman

Options: ReplyQuote


Subject
Views
Written By
Posted
no match variable
3663
October 18, 2004 08:22AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.