MySQL Forums
Forum List  »  Replication

Doesn't replicate insert statements
Posted by: Gharieb Abdel-Mawla
Date: April 02, 2009 06:38AM

I have configured master-slave Replication
and the replication format was MIXED by the command
SET GLOBAL BINLOG_FORMAT=MIXED
when I deleted some records from the master these were replicated on the slave and the record's count was the same in both of them.
but when I tried to insert a single record into the master's table it wasn't replicated on the slave !!
moreover any other deletion process(that worked before the insert statement) wasn't replicated also .
So, I restarted the service on the slave,and then started the slave again.
(NOTE:the record's count is not the same)
when I tried to delete 10 records from the master ,the record's count on the slave is decreased with 10 records -that deleted from the master - but still the record's count is not the same in both of them (that means the changes before restarting the service were not replicated)!!
1-Why the insertion statement was not replicated and after it the slave was stopped?
2- If there was an error or the data is not the same,how can I instruct the slave to replicate all the missing data ?(as the previous case).

Thanks

Options: ReplyQuote


Subject
Views
Written By
Posted
Doesn't replicate insert statements
3572
April 02, 2009 06:38AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.