MySQL Forums
Forum List  »  Replication

Replication Issues
Posted by: X X
Date: December 16, 2009 03:19PM

I'm trying to reload the databases from master to slave. The slave is too far behind to catch up. When I ran 'flush table with read locks' I recorded the binlog and position for after the dump I unlock the tables and then load the dump onto the slave. The master is on mysql-bin.002147 and position is 13086021 so I lock the tables on the master again and on the slave I run SELECT MASTER_POS_WAIT('mysql-bin.001952', 13086021) but my slave is on mysql-bin.000001 and the position is way off. Do I still need to run CHANGE MASTER TO MASTER_LOG_FILE='mysql-bin.001952',MASTER_LOG_POS=13086021;?? Why doesn't the slave start with with mysql-bin.001952 and in /var/log/mysql/ on the slave the mysql-bin starts at 00001 to 000130. Should I delete files and mysql-bin.index? The slave I/O and SQL thread is running and it continues to read the mysql-bin files but nothing gets updated to the databases. Please help.

Options: ReplyQuote

Written By
Replication Issues
December 16, 2009 03:19PM
December 29, 2009 09:59PM
December 30, 2009 08:31AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.