MySQL Forums
Forum List  »  Backup

mysqldump
Posted by: Cory Pierce
Date: January 11, 2005 08:51AM

Having some problems getting a good database dump.

We are currently trying to migrate an old MySQL server ( version 3.23.31 debug ) to a new server ( version 4.1.8 NT ). I am 'very' new to MySQL and hence not familiar with Database backup or maintience. From what I understand because the existing Server is running at 3.23.31 I do not have any options for mysqlcheck or mysqlhotcopy. Therefore I "believe" that I am stuck with mysqldump and myisamchk for doing maintience and backups. The following is what I have tried so far to no avail.


- Have tried doing individual dumps of the database's ( 4 total ), one dumps fine and can be restored to another server and functions fine. The other three just hang when I try to dump them ( will sit there for hours on end if I let them ), if I Cntl C out I get no error message ( at the command prompt ) and the dump actually creates a file with some size but I am unable to restore the dump to my new server ( just hang in the middle of the restore ).

- If I try to do a myisamchk on "database 1.ism" then I get a error "myisamchk: error: 'database 1.ism' doesn't have a correct index definition. You need to recreate it before you can do a repair.

From what I understand to recreate the index I have to use something like the repair table command ( or mysqlcheck, which is not an option ). Is there a query tool for version 3.23.31? I have found the one that is for version 4 and up but, when you try to connect to 3.23.31 is says that using this might result in unexpected behaviour.

HELP !!

Options: ReplyQuote


Subject
Views
Written By
Posted
mysqldump
4972
January 11, 2005 08:51AM
2965
January 13, 2005 09:51AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.