MySQL Forums
Forum List  »  Backup

mysqldump / utf8
Posted by: Hans Scholte
Date: February 08, 2017 04:24AM

hi,

I have some trouble dumping and re-importing my sql database and data.
I load data with a Perl script into a MySQL database. When quering the data everything looks fine. When dumping the data with mysqldump some chars are garbled. I googled quit a bit, tried a lot of thing but with no luck. Hope anybodye here could help me out.

Some info:
MySQL version: 5.0.95
I created the database script with MySQL Workbench 6.3, default collation latin1, tables utf8 (I also tried both utf8).
After loading the database en querying a title it looked ok
After dumping and re-importing it on another system the data was corrupted.
The letter 'ü' came out as (hex) C3BC and was not shown properly.
C3BC is binary 11000011 10111100 -> 2 bytes of utf8 -> gives [110]00011[10]111100 -> FC = 'ü'

What is going on here? And what am i doing wrong?

Regards,
Hans Scholte

Options: ReplyQuote


Subject
Views
Written By
Posted
mysqldump / utf8
757
February 08, 2017 04:24AM
455
February 08, 2017 01:23PM
381
February 09, 2017 01:14AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.