MySQL Forums
Forum List  »  MySQL Administrator

Re: Err 1142 ANY command denied to user
Posted by: WebPat ME
Date: August 17, 2009 06:17PM

I wish I could interpret the message, but unfortunately, that is almost the literal message. I tried a search of the documentation on ANY but the documentation didn't have it indexed either.

But, I did solve the problem. I had the proper rights because I was able to create a simple View on the same table.

The problem is that the sql script (the View DDL) was extracted from my working View in my own shop. It included fully qualified table names in the From and Join statements. (database.tablename). It was this the ISP's installation didn't like. When I simply removed the databasename from the entire script, it worked as intended. I thought that was the flaw.

But I had one more problem pending. My website was having trouble connecting to Mysql. Seems the databasename is not as I expected. The website runs under an administration program, C-Panel, which prefixes the database name. I didn't learn that until I also got the connection problem worked out.

So, the error was caused by a non-existant databasename in my sql script. I assume it would work if I had the correct database name. That error was trying to tell me it didn't know the database.

Now, that's my interpretation!

Options: ReplyQuote

Written By
Re: Err 1142 ANY command denied to user
August 17, 2009 06:17PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.