Extremely slow inplace upgrade from 5.7.x to 8.0
Posted by: Tomáš Bleša
Date: July 07, 2021 05:33AM

One of our database admins tried to update Ubuntu server together with MySQL 5.7 to newer Ubuntu with MySQL 8. That was 15 days ago and the upgrade is still running!!
We have ~540 databases on that machine (350 GB of data). There is this process in the memory:

mysqld --user=mysql --daemonize --socket=/tmp/tmp.SdlzoTUZOv/mysqld.sock --pid-file=/tmp/tmp.SdlzoTUZOv/mysqld.pid --skip-networking

We see files being changed on the disk but upgrade doesn't produce any log file or any kind of report. We don't know WHEN/IF it ends? All databases are InnoDB with directory for each DB.

The server has SSD and 6-core CPU (but "top" shows ~200% CPU use).

We are kind of desperate here because some of our backups were incomplete and we realized that when it was too late. We are afraid to kill mysqld process to prevent data corruption.

My questions are:
- Is such long upgrade process common?
- If no, what could probably cause it?
- Is there a way to see how much of the upgrade is done and how long it takes to finish?
- Is there any way how to get to the data? (We tried tools like "Undrop for InnoDB", "InnoDB Java Reader" without much success).
- Any other suggestions what to do?

Thank you.

Options: ReplyQuote

Written By
Extremely slow inplace upgrade from 5.7.x to 8.0
July 07, 2021 05:33AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.