MySQL Forums
Forum List  »  Connector/ODBC

Re: Installation fails with El Capitan
Posted by: Gonzalo Moreno
Date: May 25, 2016 03:58AM

Yeah, sure.

First of all: I thought it was going to work, but it doesn't, as it install ok, but it looks like there is another issue.

Anyway, I will share my path with you:

Brew is a package manager for Mac OS, as the package managers in Linux (apt, yum, pacman,...).

So you can install or update packages with a command line.

First of all I tried to install the MySQL ODBC driver as DMG:

It fails, and I saw that it was a known issue, so I tried to install it from the tar file, from the same website, and following this steps:

I had to do few modifications (as access the directory after extracting it, or create missing paths):

# Uncompress the downloaded "Mac OS X 10.11 (x86, 64-bit), Compressed TAR Archive" file
tar xvzf mysql-connector-odbc-5.3.6-osx10.11-x86-64bit.tar.gz

# Access the directory generated
cd mysql-connector-odbc-5.3.6-osx10.11-x86-64bit

# Create missing directory that we will need...
mkdir /usr/local/lib

# Copy Files to user local bin and lib
cp bin/* /usr/local/bin
cp lib/* /usr/local/lib

# Run the installer
myodbc-installer -a -d -n "MySQL ODBC 5.2 Driver" -t "Driver=/usr/local/lib/"

It gives me the error that all we know:

$ myodbc-installer -a -d -n "MySQL ODBC 5.2 Driver" -t "Driver=/usr/local/lib/"
dyld: Library not loaded: /Volumes/hd2/pb2/build/sb_0-18231254-1457619324.6/unixODBC-2.3.2-osx10.11-x86-64bit/lib/libodbc.2.dylib
Referenced from: /usr/local/bin/myodbc-installer
Reason: image not found
Trace/BPT trap: 5

Then I search for that missing file, and I found those pages:

Where they suggest to install unixodbc to fix the problem, with the command:

# brew install unixodbc

Then I tried to install MySQL ODBC driver again, and it worked:

$ myodbc-installer -a -d -n "MySQL ODBC 5.2 Driver" -t "Driver=/usr/local/lib/"

To verify the installation:

$ myodbc-installer -d -l
MySQL ODBC 5.2 Driver

Everything was fine so far, but... when trying to use the migration tool, there was another error:

The ODBC driver that was selected for the source connection was not found by the ODBC manager.
Ensure that you have the proper ODBC driver installed and retry.

Error Text: Error("('00000', '[00000] [iODBC][Driver Manager]dlopen({SQL Server}, 6): image not found (0) (SQLDriverConnect)')"): error calling Python module function DbMssqlRE.connect

So sorry for the false expects, I’m still on it. I'll let you know if I find out something else…

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.