Problems with execute query with JDBC
Posted by: Alfred Pimminger
Date: July 26, 2004 07:00AM

I've written an JDBC interface.
Works fine when i read data from the mysql database.

But when I want to write something I got this error message:
"java.sql.SQLException: Can not issue data manipulation statements with executeQuery()"

here is the javasnippte with which I've tried this:
resultSet = statement.executeQuery(query);
}catch (SQLException ex){
case 1062:SystemMessage.print("Dataset already exists",
ErrorCode = 2;
default:SystemMessage.print("Error/Warning during execution"+
"\r\n ErrorCode: " +
String.valueOf(ex.getErrorCode()) +
"\r\n ErrorMessage: " +
ErrorCode = -1;

This snippet had worked 2 years ago ... now I wanted to program new things.. but what should i program when even the old snippet are not working.
I thought of an error with the login permission ... but this can't be the problem because I'm able to read ... and I set all the parameter of the user to 'Y'
Has anyone a suggestion?
I got stuck because of this problem.

Options: ReplyQuote

Written By
Problems with execute query with JDBC
July 26, 2004 07:00AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.