error with "characterEncoding=ucs2"
Posted by: captaing gerry
Date: October 11, 2004 02:20AM


When I use the following url in java to create Db connection, there is an error...


SQLException: Syntax error or access violation message from server: "You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '��<two square box here>' at line 1"
SQLState: 42000
VendorError: 1064

if I switch to other characterEncoding, let's say, utf-8, there won't be such an error.
I know mysql jdbc has support for character set "ucs2", but why I couldn't use it as in above URL?

I have tried with old and new versions of mysql, and they have same problem...

Anybody have tried this before?

Great Thanks...


Options: ReplyQuote

Written By
error with "characterEncoding=ucs2"
October 11, 2004 02:20AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.