MySQL Forums
Forum List  »  Delphi

Re: row could not be located for updating
Posted by: Angelin Lalev
Date: February 16, 2007 03:40AM

Solved...sort of...

I changed the connection string with

DRIVER={MySQL ODBC 3.51 Driver};; PORT=3306; DATABASE=myDatabase; USER=myUsername; PASSWORD=myPassword; OPTION=3;

thanks to Zarko Gajic -

OPTION = 3 seems to indicate

1 Don't Optimized Column Width The client can't handle that Connector/ODBC returns the real width of a column.
2 Return Matching Rows The client can't handle that MySQL returns the true value of affected rows. If this flag is set, MySQL returns “found rows” instead. You must have MySQL 3.21.14 or newer to get this to work.

I guess this overrides the options in the ODBC administrator when using
pre-configured DSN.

But after that tere is still no change - the fields are padded with space.

Changing CHAR fields to VARCHAR solved the problem for me, but I'm still curious
is that a bug?

Let's mention my config again: Delphi 2006, MySQL 5.0.27 and MySQL Connector/ODBC 3.51.12.

Edited 1 time(s). Last edit at 02/16/2007 03:55AM by Angelin Lalev.

Options: ReplyQuote

Written By
Re: row could not be located for updating
February 16, 2007 03:40AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.