MySQL Forums
Forum List  »  Connector/Python

Load Data Infile error with local-infile option enabled
Posted by: Mike Magnuson
Date: February 12, 2013 01:28PM


I'm trying to load a local csv file into my database with the command LOAD DATA LOCAL INFILE '/tmp/myfile.csv' FIELDS TERMINATED BY ',' OPTIONALLY ENCLOSED BY '"'

I'm getting the following error.
"Error Code: 1148. The used command is not allowed with this MySQL version"

I've looked around and apparently, I need to make changes to my.cnf to allow loading LOCAL files.

I've made all the changes that I've seen required and restarted the mysql server, but I still receive the same error message.

Snippets of my.cnf :::
local-infile = 1

local-infile = 1

local-infile = 1

I can also verify that this option gets set when mysql is started because "show variables" returns: local_infile ON.

Everything I know to check is reporting that the local-infile option is enabled, but I still get the error "The used command .... ".

Any ideas on what else I can check?

I'm running Mysql version 5.5.29 on Ubuntu Linux x64 on my local dev machine.

Edited 1 time(s). Last edit at 02/12/2013 01:28PM by Mike Magnuson.

Options: ReplyQuote

Written By
Load Data Infile error with local-infile option enabled
February 12, 2013 01:28PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.