MySQL Forums
Forum List  »  Perl

library linking issue - it's got to be an easy one for someone (not me though)
Posted by: adam juntunen
Date: May 02, 2008 02:15PM

I'm trying to load monarch and I'm pretty close. I've installed all required perl modules and I can run the monarch.cgi from the command line, just not from a browser.

From the browser, I get this error in the apache logs "install_driver(mysql) failed: Can't load '/usr/local/lib/perl5/site_perl/5.8.8/sun4-solaris/auto/DBD/mysql/' for module DBD::mysql: perl: fatal: open failed: No such file or directory at /usr/local/lib/perl5/5.8.8/sun4-solaris/ line 230"

In order to get the monarch.cgi perl script to run from the command line, I need to enter "export LD_LIBRARY_PATH=/usr/local/mysql/lib/mysql", so I know there's a shared library problem.

I've tried the following
1) in the .profile for the apache user, I added
export LD_LIBRARY_PATH=/usr/local/mysql/lib/mysql
2) in the monarch.cgi script, I added
system('export LD_LIBRARY_PATH=/usr/local/mysql/lib/mysql');

But I still get the error in the browser and I'm at my wits end. I've got to do a nagios demo next week and then microsoft will do a mom demo, so I really need the monarch functionality.


Options: ReplyQuote

Written By
library linking issue - it's got to be an easy one for someone (not me though)
May 02, 2008 02:15PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.