MySQL Forums
Forum List  »  Perl

Re: DBD::mysql compiled OK, but "make test" fails -- 32 vs 64 bit issue
Posted by: Peter Levine
Date: September 21, 2010 01:49PM

Try as I might, I was never able to force the linker to use 64 bit libraries. Turns out that I'd compiled a 32 bit perl (the default according to the perl documentation). I tried to recompile perl as 64 bit (-Duse64bitint) but things were still not working. So I installed a 32 bit mysql 5.1.50 package and used the 32 bit perl.

Then when I tried to "make" DBD::mysql again, I got these errors:
gcc: dbdimp.o: No such file or directory
gcc: mysql.o: No such file or directory
I had to tweak the Makefile by removing -mt, -m32, and -xarch=sparc. That allowed "make" to succeed. After that "make test" succeeded without error. Finally!

Hopefully this information will help someone who is scouring the web and looking at as many posts regarding this problem as I did.

Options: ReplyQuote

Written By
Re: DBD::mysql compiled OK, but "make test" fails -- 32 vs 64 bit issue
September 21, 2010 01:49PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.