MySQL Forums
Forum List  »  Microsoft SQL Server

Four part queries - worked in SQL 2005 / 32-bit but not SQL 2008 / 64-bit
Posted by: Wayne Erfling
Date: January 04, 2011 11:22AM

I'm finding that when we migrated from SQL 2005 / 32-bit (32-bit MySql ODBC) to SQL 2008 R2 / 64-bit (64-bit MySQL ODBC), we lost the ability to use four-part notation.

That is, a query like:


worked prior to this migration, but now issues the following error:

Msg 7313, Level 16, State 1, Line 1
An invalid schema or catalog was specified for the provider "MSDASQL" for linked server "LINKED_SERVER".

Note that the query only uses the "empty" / "..." form of four-part notation, as the MySql driver clearly does not support CHANGING the schema.

We are only trying to access the same database declared in the MySQL ODBC Data Source and the linked server itself.

While we can rewrite every query with OPENQUERY(), this is somewhat cumbersome, especially for ad hoc queries.

I'd really like to hear of anybody who is successfully using four-part SQL Server notation with linked servers from 64-bit SQL Server 2008 R2.

Options: ReplyQuote

Written By
Four part queries - worked in SQL 2005 / 32-bit but not SQL 2008 / 64-bit
January 04, 2011 11:22AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.