MySQL Forums
Forum List  »  IBM DB2

MYSQL to DB2 Migration
Posted by: hawk sury
Date: July 26, 2010 01:00PM

Dear All,

I am running the following mysqldump command to backup one of the tables to
DB2.

mysqldump -u root -p --compatible=db2 mydatabase mytable>C:\backup\mytable

It actually works fine and generates a backup file. The problem is that it un-necessarily adds a '\n'prefix to the every first column element of each row.
(Apart from the very first element of the first column)

The output is as following,

Insert into mytable Values (id, europe,100),(\nid2,europe,102),
(\nid3,europe,103) ........... and so on

The \n is added by mysql unnecessarily.
Does anyone know how to stop mysql from putting \n un-necessarily OR
If there is any option in IBM DB2 that can just avoid \n while
loading files.

I would appreciate if you could help.

Thanks for reading,

hawksury

Options: ReplyQuote


Subject
Views
Written By
Posted
MYSQL to DB2 Migration
6929
July 26, 2010 01:00PM
3701
July 26, 2010 05:39PM
3275
July 27, 2010 06:36AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.