MySQL Forums
Forum List  »  Microsoft Access

Migration Tool...Does it really work???...Update: Actually, it does!!!
Posted by: stepher r
Date: December 24, 2005 09:11PM

This is an update: After further study I tried a couple of changes to the information I provided for the migration and went to a smaller Access DB to check out the results. Lo, and behold, the transfer worked, flawlessly.

The 2 changes I made (and I'm not sure which one, if either, really solved the problem) are 1) providing a user name for the Access DB even tho I have no password security set since I am the only user on my system, 2) I set another Access system table, "MSysRelationships", to Administer (under the "Tools/Security/Users and Group Permissions"). The instructions for preparation of an Access DB mentions setting only 2 tables, "MSysObjects" and "MSysQueries", but one of the messages I got early on mentions about being unable to determine relationship information (tho, these may be completely unrelated to each other).

One other thing I realized is the need for patience (in my case, anyway). It turns out the DB that I am trying to migrate takes more time than I thought (based on my experiment with the smaller DB).

Anyway, I am now on the "migration" path :)

Steph

I know this topic has come up (I also started a thread on the Migration Tool forum and Sebestien C. has been kind enough to offer his help...but to no avail so far :(

I have all the latest WinXP s/w with all the patches. I have been trying to migrate an Access 2003 DB to MySQL without much success. Here's what I know so far:

1. If I export a table from Access to MySQL, it (the processing) seems to take much longer than I would expect (but maybe that's OK). When I use the MySQL Browser to look at the table, however, the structure seems to have made it, but none of the data has.

2. Using MT (Migration Tool), I get as far as the screen that says it's going to do reverse engineering and then everything freezes (have to use Task Manager to exit). The screen previous (or 2 screens previous) where I can look at how the connection process is proceeding looks like connections both directions appear to be OK (but then I am unsure what might be posted if things weren't going well). Here's the dialog from the connection screen:

Connecting to source database and retrieve schemata names.
Create a dummy schema list because Access only has one schema for each file.
Return schemata list.
Schemata names retrieved successfully.
Initializing JDBC driver ...
Driver class MySQL JDBC Driver 3.1
Opening connection ...
Connection jdbc:mysql://localhost:3306/?user=******&password=****&useServerPrepStmts=false
Getting version information ...

Is this consistent? At the Reverse Engineering screen, nothing is checked off and a message near the bottom middle says "Opeing connection...." and that's as far as I've ever gotten......

3. When I was using MySQL4.X , this problem never seemed to happen. In fact, I moved over multiple DBs from within Access without any difficulties or problems.

Anyone have any clues on this?

Thanks in advance and happy holidays to all.

Regards...Steph



Edited 5 time(s). Last edit at 12/25/2005 02:21PM by stepher r.

Options: ReplyQuote


Subject
Views
Written By
Posted
Migration Tool...Does it really work???...Update: Actually, it does!!!
2366
December 24, 2005 09:11PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.