MySQL Forums
Forum List  »  Stored Procedures

Re: SOLVED: Restore of mysqldump fails consistently
Posted by: Ken Gregg
Date: April 16, 2012 01:27PM

The comment syntax reported previously turned out to be a red herring. The 'real' problem is that mysqldump is interpreting the word 'function' in comments in SOME cases as a function name and incorrectly inserting the function meta-commands.

For example this comment:
/*
This procedure uses the sp_example_1 function to edit parameters
*/

Gets dumped by mysqldump as:
/*
This procedure uses the sp_example_1*/ /*!50003 function to edit parameters
*/

Haven't figured out what triggers this, as some comments have the word 'function' which do not get mangled. It appears that if it refers to a real function name, such as 'sp_example_1' in this case precedes the word 'function', it happens, otherwise not. (Also have a few cases where wording such as 'this function' causes it to happen.) The exact effect varies depending on what follows the resulting malformed comment, but generally an attempted restore using the mysqldump generated script fails. I am not familiar with the bug reporting process - should I report this and how would I do so?

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: SOLVED: Restore of mysqldump fails consistently
1335
April 16, 2012 01:27PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.