MySQL Forums
Forum List  »  Newbie

There is no 'root'@'%' registered
Posted by: Frank Fox
Date: December 09, 2008 07:46PM

Moving a cleanly running web application from a desktop machine to a laptop in order to make a presentation to a client in a remote location. Both machines Windows XP Pro. I use MySQLAdministrator (etc) for the interface. I've never used the command line.

Connection string on desktop:
"server=SVR2003;Database=tnhorse;Data Source=SVR2003;user id=root;password=XXX;"

Connection string on laptop:
"server=localhost;Database=tnhorse;Data Source=localhost;user id=root;password=XXX;"

I tried using the actual computer name with the laptop (like the desktop) but I kept getting the message the "Host 'DellLT' is not allowed to connect to this MySQL server". I read online somebody tried "localhost" in place of the server name and it worked. It did so for me and at least got me into MySQLAdministrator! In the web.config file, however, I get "There is no 'root'@'%' registered".

I hoped to show the application to my client tomorrow (12/10) but I'm completely stumped. I know there is a simple solution to this but being a relative newbie to MySQL (which I really like) I need somebody to give me step by step instructions.

MySQL 5.0 ASP.NET 2.0 running in XP Pro.

Any help will be seriously appreciated. Thanks in advance.

Frank Fox
Hendersonville, Tennessee

Options: ReplyQuote

Written By
There is no 'root'@'%' registered
December 09, 2008 07:46PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.