utf8 character set error
Posted by: Peter Chen
Date: March 05, 2005 08:56PM

I have reported this question(http://bugs.mysql.com/bug.php?id=8943). But Mr Heikki Tuuri told me it is not a problem. But his answer can not solve my problem at all. I wish someone can tell what I can do. Thank you very much!

Below is the bug report:


Description:
In my InnoDB table, I have a CHAR(16) column which is used to save password.
When I tried to save a character "0x9d" into this column. It converted to
"0x3f".
My table is using utf8 character set. I tried all the characters and I found
that four other characters - "0x81","0x8d","0x8f","0x90" would be converted to
"0x3f". But when I converted the table to latin1 character set, it worked very
well. Below is my basic situation:

OS: Win 2000 Pro
Cluster: 4.1.7
engine: InnoDB

How to repeat:
mysql> Create table test (col1 char(16));
mysql> INSERT INTO test VALUES
(CHAR(129,141,143,144,157,129,141,143,144,157,129,141,143,144,157,129));

Suggested fix:
Tell me why

Options: ReplyQuote


Subject
Views
Written By
Posted
utf8 character set error
3298
March 05, 2005 08:56PM
2733
March 06, 2005 07:24PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.