Re: Getting strange characters using latin1 with latin1_swedish_ci
Posted by: George Miguel
Date: January 15, 2006 10:25PM

I had this same problem after an upgrade. Using SELECT HEX... above helped me verify that the data was stored correctly in latin1 and the problem was somewhere else. If you have this problem, it simply means your data is stored correctly, but whatever interface you're using to communicate with the database is munging it.

I set:
init-connect="SET NAMES latin1"
and
default-character-set=latin1

in the [mysqld] section of the my.cnf file, and everythying worked fine.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Getting strange characters using latin1 with latin1_swedish_ci
3273
January 15, 2006 10:25PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.