Loading Data Files with umlaut in file name
Posted by: Stuart Rundlett
Date: September 14, 2005 11:18AM

When submitting the following SQL via MyODBC from Visual Fox Pro 8.0 (Win 2k):
LOAD DATA LOCAL INFILE 'C:\\AUGSBURGDEV\\FIBERDATA\\30 DÄNE.csv' INTO ....
the following error is received:
File 'C:\AUGSBURGDEV\FIBERDATA\30 DÄNE.csv' not found (Errcode: 2)

It appears that the Ä character in the file name is mangled into "Ä" . The file "30 DÄNE.csv" does exist, and the error can be avoided by renaming the file to use A instead of Ä.

The server is MYSQL 4.1 with character set latin1. I tried setting the collation to latin1_german1_ci but it did not seem to make any difference. The same error occurs from client PC's with Windows localization set for either Germany or US.

The same problem (can't find file) occurs when the same SQL is entered from MySQL Query Browser, although in this case the file name is correct in the error message. However data containing German characters can be loaded into the data base with no problem.

Any idea what setting is missing to handle umlaut in file name, or is this a bug?

Options: ReplyQuote


Subject
Views
Written By
Posted
Loading Data Files with umlaut in file name
2886
September 14, 2005 11:18AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.