Blackhole engine and utf8 character set
Posted by: Craig Healey
Date: October 23, 2020 02:53AM

I'm replicating a 5.5 DB to 5.6. The default storage engine on 5.5 is InnoDB, and on 5.6 is Blackhole. The character set system variables are all the same. Creating the tables, all work except one.

create table t1 (
`uuid` varchar(255) NOT NULL,
`device_uuid` varchar(255) NOT NULL,
`created_at` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
`updated_at` timestamp NULL DEFAULT NULL,
PRIMARY KEY (`uuid`,`device_uuid`,`created_at`)
) DEFAULT CHARSET=utf8;

ERROR 1071 (42000): Specified key was too long; max key length is 1000 bytes

I can create the table as InnoDB, and I know utf8 in MySQL isn't "actually" utf8. But I wondered if anyone knew the reason why InnoDB and Blackhole don't produce the same error?

Options: ReplyQuote


Subject
Views
Written By
Posted
Blackhole engine and utf8 character set
111
October 23, 2020 02:53AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.