MySQL Forums :: Install & Repo :: mysql error #1064 with latest wamp install


Advanced Search

mysql error #1064 with latest wamp install
Posted by: steph mc ()
Date: June 14, 2012 07:21AM

I had Wamp server working perfectly fine, with prestashop installed just 3 days ago, then attempted to try magento, in which wampserver 2.2 apparently doesnt work with, so i downloaded the reccommended extenstions suggested in forums etc to get magento to work with wampserver 2.2. I evan attempted using xampp but finally gave up and decided to stick with prestashop, as im not keen on doing to much configuration within the files etc.

So i removed xampp from my computer, including files etc, and attempted to re-install WAMPSERVER as i had uninstalled it.

Wampserver installs fine, but when it comes to "create database" to install prestashop within, it says

#1064- You have an error in your SQL syntax, check the manual that corresponds to your MYSQL server version for the right syntax to use near " at line 1

So i uninstalled Wampserver, and re-installed again, thinking it may have been an error on my behalf with install, and again same error message...

So i unintalled again, cleared my browser chache, cookies etc, then re-installed, only to receive the same error message when creating a database.

As my laptop is fairly new, i cleared/saved the items i wanted to keep on a hardrive, and did a complete system restore back to manufactuer settings, to remove any configurations, or alterations i may have made, then went onto wampservers website, and did a fresh download of wampserver 2.2

... only to be greeted with that lovely error message, and this is just from "as is" download, not alterations, extentions etc...

so looking for answers on how to fix this error, i found many people who have the same error message, but their error message points them towards the problem area, such as
"...right syntax to use near 'database' at line 1"
"...right syntax to use near 'plugi ns' at line 1"
"...right syntax to use near ''dbname-with-dash'' at line 1" etc

where as my error just says
"...right syntax to use near " at line 1"

so im confused, im new to localhosts, virtual servers etc, and had it working out the box, however now it displays the error, and theirs no guides on what to fix, or how, and upon pressing the ? symbol, i was led to this website, so im hoping someone may be able to assist me, or give me a very simple instructional on how to fix this error.

Any assistance is greatly appreciated.

Options: ReplyQuote


Subject Written By Posted
mysql error #1064 with latest wamp install steph mc 06/14/2012 07:21AM
Re: mysql error #1064 with latest wamp install Barry Galbraith 06/14/2012 05:28PM
Re: mysql error #1064 with latest wamp install steph mc 06/14/2012 08:43PM
Re: mysql error #1064 with latest wamp install steph mc 06/14/2012 08:58PM
Re: mysql error #1064 with latest wamp install Barry Galbraith 06/14/2012 09:33PM
Re: mysql error #1064 with latest wamp install steph mc 06/15/2012 12:09AM
Re: mysql error #1064 with latest wamp install Barry Galbraith 06/15/2012 05:01AM
Re: mysql error #1064 with latest wamp install Leo Agustinus 06/19/2012 11:45AM
Re: mysql error #1064 with latest wamp install Peter Garcia-Webb 06/23/2012 08:43PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.