MySQL Forums
Forum List  »  Install & Repo

Failed to set datadir to new with error MY-013276]
Posted by: Carol Guo
Date: March 29, 2021 06:56AM

I am installation Version 8.0.23-commercial, and it can start up correctly after rpm installation. Then I did below steps to change datadir to another FS:
service stop
vi my.cnf to edit datadir=newFS
set newFS owner with mysql.mysql
copy the original data files to the newFS
service start
I got below error message in "journalctl -xe":
[Warning] [MY-010091] [Server] Can't create test file /app/mysql/data/mysql/mysqld_tmp_file_case_insensitive_test.lower-test
[System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.23-commercial) starting as process 5153
[Warning] [MY-010091] [Server] Can't create test file /app/mysql/data/mysql/mysqld_tmp_file_case_insensitive_test.lower-test
[Warning] [MY-010159] [Server] Setting lower_case_table_names=2 because file system for /app/mysql/data/mysql/ is case insensitive
[ERROR] [MY-013276] [Server] Failed to set datadir to '/app/mysql/data/mysql/' (OS errno: 13 - Permission denied)
[ERROR] [MY-010119] [Server] Aborting
[System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.23-commercial) MySQL Enterprise Server - Commercial.
MySQL systemd[1]: mysqld.service: Main process exited, code=exited, status=1/FAILURE
MySQL systemd[1]: mysqld.service: Failed with result 'exit-code'.

Did I miss some step? Or what should I do to fix such error? I also tried to use command "mysqld --initialize --console --user=mysql" but the same error. Please help me! Thanks!!!

Options: ReplyQuote

Written By
Failed to set datadir to new with error MY-013276]
March 29, 2021 06:56AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.