Reduce Apache-Tomcat memory footprint
Posted by: Fabio Bozzo
Date: June 07, 2012 10:28AM

This is my Tomcat tomcat\bin\setenv.bat (windows installation).

set JAVA_HOME=D:\MYSQL_~2\SERVIC~1\java
set JAVA_OPTS= ++JvmOptions="-XX:+UseParallelOldGC" ++JvmOptions="-XX:+UseBiasedLocking" ++JvmOptions="-XX:+HeapDumpOnOutOfMemoryError" ++JvmOptions="-XX:HeapDumpPath=D:\MYSQL_~2\SERVIC~1\apache-tomcat\temp" ++JvmOptions="-Xms128m" ++JvmOptions="-Xmx256m" ++JvmOptions="-XX:MaxPermSize=256m"

I suspect that it's not read by the service manager tomcat instance.
I want to keep the memory occupation below 200M (I mean by looking at tomcat6.exe in task manager).

It goes always above 400M! What's wrong?

I also tried to decrease that params in a crazy way (eg. 32m each size) but it's still growing.... :(

What's the right place for putting additional tomcat jvm arguments?

Options: ReplyQuote


Subject
Views
Written By
Posted
Reduce Apache-Tomcat memory footprint
4133
June 07, 2012 10:28AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.