Can't Read or Update Java Keystore - *** SOLVED **** Please disregard ***
Posted by: Preston Durrer
Date: May 18, 2018 08:28AM

Please Disregard - Problem Has Been Solved

I created a password on the keystore and I just needed to make a small change to the tomcat server.xml file.



We’re running MySQL Monitor The original self-signed certificate on our MySQL Monitor server has expired and I was trying to generate a new one using the instructions here:

It appears the default keystore password is the empty string. Anyway, I’m able to examine the keystore using this command and entering an blank password:

$INSTALL_ROOT/java/bin/keytool -list -v -keystore $INSTALL_ROOT/apache-tomcat/conf/keystore

However, when I try to recreate the keystore with a new certificate with this command:

$INSTALL_ROOT/java/bin/keytool -genkey -keyalg RSA -sigalg SHA256withRSA -keystore $INSTALL_ROOT/apache-tomcat/conf/keystore -alias tomcat -validity 365 -keysize 2048

I’m unable to recreate it using an empty password, as the password must be at least six characters. Is there anyway around this? I’d rather not have to fiddle around with the existing tomcat configuration files.


Edited 2 time(s). Last edit at 05/18/2018 09:17AM by Preston Durrer.

Options: ReplyQuote

Written By
Can't Read or Update Java Keystore - *** SOLVED **** Please disregard ***
May 18, 2018 08:28AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.